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1. INTRODUCTION 
 

Welcome to the Panzer Corps editor tutorial!  This document 
will introduce you to the basic functionality of the editor, as 
well as walk you through the creation of your first scenario! 
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2. GETTING STARTED 
 

The Editor can be found through your start menu short cut. 
 
Alternatively, you can also find in the folder where Panzer 
Corps was installed. The exact file name is Scenarioeditor.exe. 
 
Once you open it, here’s what the editor looks like: 

 
 
As we explore the editor, everything you see here will be 
explained, but for now you should be aware the area on the 
left can be expanded or shrunk at will.  Just grab the divider 
line adjacent to the scroll bar to change the width of the left 
area. 
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3. TOOLBAR 
The toolbar lets you configure you view in various ways. The 
icons are explained below in order from left to right.  
 

 
 

 Toggle map hexes. 

 Toggle map border.  You’re playing on a rectangular 
map with hexes, so there are going to be a few ‘half’ or 
completely impassable hexes. This toggle tells you 
where that boundary lies. 

 Toggle air/ground units.  If you want to edit a hex with 
both an aircraft and a ground unit, use this toggle to 
modify the precise unit you want to. 

 Transport toggle.  When this icon is depressed the game 
will show transports units have instead of the unit 
themselves. 

 Unit Filter, lets you configure which units are displayed. 
For details see the View section.  

 About the scenario editor. 
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4. “EDIT” PULL DOWN TAB 
The guts of your scenario are edited here. This is where you 
select the layer you are editing.  Notice that ‘units’ is 
highlighted, and the left sidebar is displaying units to place. 
These are explained from top to bottom. 
 

4.1. Terrain: This option allows you to 
place actual terrain.  Clear, Lakes, 
Deep Sea, Rough, Cities, Airfields, 
et cetera. Simply select your 
terrain tile of choice, and click 
where you want to place it on the 
map. Hold shift and click to fill in 
an area.  Careful though, there’s 
no ‘undo’ button! You can 
immediately see the terrain you 
place if you are in ‘space bar’ 
mode, but in order for the game 
to ‘draw’ your terrain placement, 
you have to ‘generate terrain’ or 
‘G’. 
 

4.2. Terrain Features. Thick blue line:  
Impassable River. Thin blue line:  
Normal River. Black line:  

Railroad. Grey line: Normal Road 
 

4.3. Tiles – Background, Coasts, Overlays…. Ports, Stations. 
All of these items allow you to place a specific appearing 
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terrain piece down.  This is NOT how you place actual 
terrain; this only allows you to customize your map’s 
appearance.  For example, under “Overlays” you can find 
several different looking ‘fortification’ looking tiles which 
you place over auto generated fortifications you placed 
with “Terrain”. 
 

4.4. Strings. Place strings on the map.  Click the string you 
want to place, and then click on the map to replace that 
hex’s string with one of your choosing.  Has no effect on 
the actual terrain.  If you rename ‘clear’ to ‘city’ it’s still a 
clear hex, it just says ‘city’ when you mouse over the hex 
in game.  Use this setting to name rivers and cities or 
specific locations. 
 
You can also right click on a hex on the map screen to 
access the ‘quick string’ pop up.  This will allow you to 
type a string to the hex you have selected, and it will 
automatically assign your string to the appropriate hex.  
Your quick string will NOT show up on the left sidebar 
until you refresh it by going to edit -> strings and re-
clicking it. 
 

4.5. Flags. Place nationality flags on the map.  Only terrain 
marked with flags are able to be captured in game.  If an 
airfield has no flag, it can never be captured and used by 
either side.  The white flag is a neutral flag that can be 
captured by either side. 
 

4.6. Special Hexes.  
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4.6.1. Grey Hex:  Neutral territory, completely 
impassable.  For example, Sweden in the Norway 
scenario.  

4.6.2. Gold Border:  Victory Hex, also known as 
Primary Objectives. 

4.6.3. Grey and Green tank and aircraft icons:  
Deployment zones.  Not used for single play 
scenarios, but necessary for creating campaigns. 

4.6.4. Gold Star:  Gold Star:  Bonus hex.  This is item 
the game uses to hand out a special string to units 
(Hoisted victory flag over HEX STRING).  Has no 
actual game play effect.  

4.6.5. Red Border:  Alternate victory hex, also known 
as Secondary Objectives. 
 

4.7. Units. Allows you to place your selected unit directly on 
the map, the unit filter button is useful for condensing this 
otherwise very large list. 
 
To give a unit a transport, place your unit first (such as: 
105mm artillery), and then select a ‘transport’ and place 
that directly on top (Opel Blitz). 
 
To customize a placed unit, shift click your placement to 
set:  Name, transport, side, flag, aux status, strength, 
suppression, experience, entrenchment, fuel, ammo, and 
AI behaviour. 
 
To place a unit on the map, left click your desired unit, 
and left click on to a vacant hex.  
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To move a placed unit, select it with left click, and then 
left click on a vacant hex to move it there. 
 
To place a copy of a unit, select your original unit, then 
shift left click on a vacant hex to place a copy there. 
 
To remove a unit from the map, right click the unit.  Be 
careful about your ground/air toggle though! 
 

4.8. Zones. Allows you to define up to 32 zones on the map.  
These will be explored later in Scenario Parameters and 
Trigger Sections. 
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5. SCENARIO PARAMETER 
The scenarios parameters are scenario wide settings that 
effect the scenario such as the length, start date, sides 
involved etc.  
 

 
 
5.1. Global Parameters.  

5.1.1. Scenario Name:  The Name your scenario will 
have in the ‘custom’ list. 

5.1.2. Scenario Description:  The short text that will be 
displayed in the map ‘text’ box found on the in 
game scenario selection screen and also in the 
custom list next to the scenario listings. 
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5.1.3. Scenario Image:  Allows the user to have a 
custom image for their scenario.  Images need to 
be placed in 
 
Panzer Corps\Panzer Corps\UI\scenarios 
 
And the optimal image size is 778x434. 

5.1.4. Turns:  Total amount of turns in the scenario. 
5.1.5. Year:  Date game takes place, important in 

regards to equipment availability. 
5.1.6. Month:  Date game takes place, important in 

regards to equipment availability. 
5.1.7. Day: Date game takes place, important in 

regards to equipment availability. 
5.1.8. Days per turn:  1 means 1 day passes per turn.  

Mutually exclusive with Turns per day. 
5.1.9. Turns per day:  2 means for every 2 turns that 

pass, only 1 day will pass. 
5.1.10. Probability of Weather:  100 – (Clouds + Rain + 

Snow) = chance for clear weather. 
5.1.11. Ground State:  Preset the ground state for turn 

1 (not permanently). 
5.1.12. Moisture:  Preset moisture level state for turn 1 

(not permanently). 
 

5.2. Sides. 
5.2.1. Name:  Name your sides.  This name appears in 

game as [NAME] Turn.  Axis Turn, German Turn, et 
cetera. 

5.2.2. Initial prestige:  Amount of prestige side will 
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start with. 
5.2.3. Core slots: Amount of core slots side will have 

for the entire scenario. 
5.2.4. Aux slots: Amount of aux slots side will have for 

the entire scenario. 
5.2.5. Unit orientation:  Affects initial unit facing for all 

units on one side. 
5.2.6. Attacker:  Chosen side is the phasing player. 
5.2.7. Unit Experience:  Changes the default 

experience amount of units both pre-placed and 
purchased mid scenario. 

5.2.8. Max Experience:  Caps unit experience in 
current scenario, useful for very long campaigns 
to control unit experience growth. 

5.2.9. Sea, air, rail transports:  Sets the amount of 
these transports available to each side. 

5.2.10. Sea, air, rail transport type:  Side 1 is currently 
restricted to German transport types, and side 2 
restricted to Allied transport types. 
 

5.3. Nations.   
5.3.1. Define which nations will be available for 

use/purchase by each side. 
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5.4. Victory Conditions. 
This area can get confusing, best to look at some 
examples: 

 
 The above image is the setting configured for USA 
Midwest campaign and scenario. ‘Allied flags’ means 
exactly that, but ‘primary objectives’ is defined by the gold 
border hexes, remember those? 
 
Campaign branch is simple.  0 means follow decisive 
branch, 1 means follow minor branch, 2 means follow loss 
branch. 
 
Turn -1 means “One turn from the end of the game (last 
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turn)”. So Turn 1,-4 means: Decisive victory if this trigger is 
satisfied between turn 1 and 4 turns from the end of the 
scenario. 

 
Hunters in the Atlantic Triggers: 
Tie game translates to: Bismarck, Tirpitz, and transports all 
sunk during the same turn.  The quick window preview 
you see above doesn’t reflect these details, but if you go 
into the ‘edit’ button, you will see these configurations in 
detail.  The below image is the exact way to configure the 
game to recognize the Bismarck as the unit attached to 
your trigger. 
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Same with Convoy Destroyed, the quick window only says 
‘all units’ but the actual details are found in the ‘edit’ 
button. 
Convoy Safely Escorted:  Remember ‘zones’?  This is how 
they are used.  Place zones on the map, and then you can 
link them to triggers.  In this map, the British mainland has 
been marked as zone 1, so units who land in zone 1 
contribute to victory. 
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5.5. Actions. 
 

 
 
The above window is for re-configuring weather conditions as 
well as prestige ‘boosts’ mid scenario. 
 
For example, this window reads:  On turn 1, set the weather to 
20% cloudy, 0% rain, 58% snow, and the remaining % is 
automatically set to clear. 
 
On turn 14, set the weather to 10% cloudy, 0% rain, 69% snow, 
and the remaining % is automatically set to clear. But because 
of how the weather works in Panzer Corps (current turn + 1 
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turn predetermined forecast) you won’t see the effects of 
these triggers for 2 turns.  If you set 1, 1, you will see the 
effects of your weather start on turn 3.  Just remember the 
Rule of Two.  Whatever turn you want to set your weather for, 
set your triggers for two turns previous.  Prestige boosts do 
not need to follow this Rule of Two. 
 
5.6. Map strings. 
This is where you will be able to type your own strings, for use 
and placement through the above mentioned “Strings” layer. 
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6. PAD IMAGE 
Question : “What’s a pad image?”  
 
Answer : The editor has the ability to load a 'pad image'. You 
can use any picture you want, and place it as the bottom layer 
of your map. You can use this image as a template to draw 
your terrain on and it gives a very easy way to create new 
maps based on real locations, great for recreating historical 
scenarios.  
 
Here's a Google Earth map of US Western seaboard I’ve 
chosen to use as my 'pad image': 
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Here I have filled in roads, railroads, and rivers with the editor: 

 
 
Next I add terrain features, such as forests, country-sides, the 
Rocky Mountains and Sierra Nevada: 
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Then I generate the terrain and it gives a very accurate 
representation of the real world geographical layout. 
 

 
 
Using this method you can easily create large maps and great 
scenarios for single or multiplayer! 
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7. “TOOLS” PULL DOWN TAB 
These are the actions you can perform from the Tools menu. 
 
7.1. Generate tiles. This converts your editor tiles to real game 

map tiles. Instead of the generic forest or mountain tile 
you’ll see real game graphics used, coastlines 
automatically generated etc. It’s very cool! 
 

7.2. Crop/Resize map.  Allows the user to resize their current 
map without needing to start over. 
 

7.3. Validate Scenario. Useful for checking your scenario has 
no errors.  Clicking this will kick out errors for hexes 
missing terrain, and other problems. 
 

7.4. Show Statistics. Useful tool for breaking down the two 
sides and their forces for the player.  Lists Total, Core, Aux 
forces, and their costs, amount of primary and secondary 
objectives. 
 

7.5. Remove all units. Does exactly that.  Be careful, there is 
no undo!  As an alternative to undo, you can always re-
open your map without saving your changes. 
 

7.6. Options. This is not currently implemented. 
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8. ZOOM 
A very simple, but useful tool.  These settings will zoom your 
map, making it easier to view large amounts of your map all at 
once, or zooming in to manage individual hexes better. 
 

9. “VIEW” PULL DOWN TAB 
 
 

Most of the items in this tab are self-
explanatory, just remember you aren’t 
actually editing through this area, you are 
only changing layer visibility.   
 
You may want to disable certain layers to 
make your work easier and cleaner to 
see, and space bar is a nice short cut for 
toggling the most significant of these 
items. 
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10. WALKTHROUGH 
Let’s make your first scenario! We’ll take you through all the 
steps you need to do it! 
 
10.1. Open the scenario editor. 

 
10.2. Press create new scenario button (the top left button). 

 
10.3. Specify the height and width of your new map 

 
10.4. Add a pad image by selecting File->Add Pad image. You 

can use anything – this is just a quick scribble I created. 
 

 
 
10.5. Now use the Edit -> Terrain mode to place terrain 

features on top of your Pad image. Draw over the blue 
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areas you want to be water with the water tile. Use forest 
tiles to fill in the green hexes for forest. Finish it off by 
placing cities and any other decorations you like and you 
will have something that looks like this: 

 
 

10.6. Now convert this in to a real map by using the Tools-
>Generate command. Or you can press the “g” key to 
generate the terrain. You will end up with something that 
looks like this:  
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10.7. Now set scenario parameters, and all sub tabs, except 
the Victory and Action tabs. 
 

10.8.  Place flags relevant to the nations you’ve selected on 
the map. 
 

10.9.  Set victory hexes – the ones with the gold borders. 

 
10.10. Set your victory triggers, based on the image above 

(Edit->Scenario Params->Victory Conditions), I decided on: 
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10.11. Place some units. Note – if you are using the Unit Filter 
and have told it to only show units available to the nations 
involved and for the time period of the scenario then you 
may find there are no units or a limited choice. Either turn 
these filters off or set your scenario parameters so that 
there are nations and a start date and you’ll see all the 
units available historically.  
 

10.12. Validate your scenario has no errors using the Tools-
>Validate scenario option. Do not worry if you see an 
error that says ‘hex needs custom string’.  
 

10.13. Now save your map and give it a name. Go to File-
>Save (I named this map alphaLake) 
 

10.14. Now it’s time to try it out! Launch Panzer Corps and 
select New game->Scenario->Custom and select the map 
you just saved. Hit play and you can test it out!  Always 
remember to play test your maps a number of times and 
tweak and improve them before offering them to others 
to play.  
 
In order to be able to access your custom map in Panzer 
Corps, once you have finished your map, place it the 
following folder:  
My Documents\My Games\Panzer Corps\Scenario 
 
Depending on your OS you may see “Documents” or” My 
Documents”.  
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10.15. You’re done with the bare bone basic requirements to 
make a map. Without too much effort you can have 
scenarios looking like this: 
 

 
Don’t forget to go back and polish your work! Now go and 
enjoy the game and the editor! 
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11. HOT KEYS 
There are a number of helpful hot keys that will make your 
scenario editing quicker and easier. A full list of them is below.  
 
• Ctrl+N - Create new scenario 
• Ctrl+O - Open existing scenario 
• Ctrl+S - Save scenario 
• 1-0 - Select layer 1-10 for editing. This lets you jump between the various 
editing layers found in the Edit menu. .  
• Ctrl+1-0  - Select layer 11-20 for editing. As above for layers 11-20 
• F1-F10 - Toggle visibility of layers 1-10. This hides or displays the layers as 
found in the View menu.  
• Ctr+F1-F10 - Toggle visibility of layers 11-20. As above but for layers 11-
20.  
• Tab - Toggle air/ground view 
• G – Generate Terrain. Tools -> Generate terrain.   
• Space - Toggle all tiles on/off. Space toggles all the details of which can be 
useful when drawing and planning actual terrain. 
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